Layer Fan wires crossed, now I have no display

Having a problem? Post it here and someone will be along shortly to help
Post Reply
TFMike
Printmaster!
Posts: 306
Joined: Fri Nov 15, 2013 9:11 pm

Layer Fan wires crossed, now I have no display

Post by TFMike »

I was fiddling with my layer fan connection just now and shorted something out. I have read some threads where people used some automotive fuses as quick fixes while they waited for the real deal to arrive. Problem is, I know barely anything about wiring at all and I am honestly surprised I was able to assemble this printer.

I have a multimeter, a soldering iron and I can get fuses but where do I need to look at first on this machine in order to narrow it down?

Machine still turns on and I can hear the fans humming but I have no display, so I guess that's a decent starting point - Rostock Max V2 machine by the way.


Any help at all is greatly appreciated, thanks.

User avatar
Jimustanguitar
ULTIMATE 3D JEDI
Posts: 2631
Joined: Sun Mar 31, 2013 1:35 am
Location: Notre Dame area
Contact:

Re: Layer Fan wires crossed, now I have no display

Post by Jimustanguitar »

Look up the Rambo board on the RepRapWiki to see where the fuses are on your particular version of the board. Mine are near where the thermistors plug in.

You can check what's good and what's bad with a continuity tester (sounds like you already know that), and then solder leads to the end-caps of the blown fuse that go to the automotive fuse-holder.

Hack at your own risk, obviously. Hope you are printing again soon!

jjjohnson
SeeMeCNC Staff
Posts: 36
Joined: Sat Jun 02, 2012 9:31 am
Location: Goshen, Indiana

Re: Layer Fan wires crossed, now I have no display

Post by jjjohnson »

You have blown the fuse in the F3 position on the RAMBO board. This is the fuse that controls logic for the board, No working fuse means no working working RAMBO.

Here is a diagram of the board layout and fuses: http://reprap.org/mediawiki/images/b/b4 ... -fuses.jpg

Here is where you can source replacement fuses:https://ultimachine.com/content/fuse-0448005mr
JJ

User avatar
mhackney
ULTIMATE 3D JEDI
Posts: 5412
Joined: Mon Mar 26, 2012 4:15 pm
Location: MA, USA
Contact:

Re: Layer Fan wires crossed, now I have no display

Post by mhackney »

Just a friendly reminder - never work on the electronics with anything powered on. If the RAMBo was powered off and you simply swapped the + and - wires on the fan it would have either run the fan in reverse or not at all but it would not have caused a problem with the RAMBo. It appears as though you shorted something working on a hot board. We've all done it! I've personally sent 3 RAMBos back to Ultibots for repair after swapping thermistors and blowing the thermistor ports. Now I always power down!

Sublime Layers - my blog on Musings and Experiments in 3D Printing Technology and Art

Start Here:
A Strategy for Successful (and Great) Prints

Strategies for Resolving Print Artifacts

The Eclectic Angler

Post Reply

Return to “Troubleshooting”