Ezstruder stepper motors are over heating

Discussions related to the Rostock MAX v2
Post Reply
karlclayton
Plasticator
Posts: 5
Joined: Tue Mar 03, 2015 11:28 pm

Ezstruder stepper motors are over heating

Post by karlclayton »

What is the correct adjustment I need to make to the firmware to stop the Ezstruder stepper motors from overheating. They are burning hot. They are MODEL: 42BYGHW81. It is melting the filament on small prints. I have been using a large fan to cool them.

Nareikuk
Printmaster!
Posts: 47
Joined: Sat Nov 22, 2014 7:18 am

Re: Ezstruder stepper motors are over heating

Post by Nareikuk »

Reduce the motor current setting for the extruder in configuration.h to around 130.

Earthbound
Printmaster!
Posts: 458
Joined: Sun Sep 07, 2014 2:39 am

Re: Ezstruder stepper motors are over heating

Post by Earthbound »

That part number is for the Wantai brand motors.

In Configuration.h, change line 701, where motor current settings are defined.
The array of settings is {X,Y,Z,E0,E1} so if you have the extruder connected in the stock manner, you want to change the E0 number.

However, the stock Wantai motors don't run hot on my Max, so I wonder if there is excessive friction somewhere in your filament path.
It shouldn't be necessary to turn down the current setting. I run my Wantai motored EZStruder at an E0 value of 200 and it never gets warmer than about 40C.

That said, try a lower setting as suggested above. It should lower the temperature, but the extruder will lose steps if path friction is the problem.
"Trust no quote from the Internet." - Abraham Lincoln

add1ct3dd
Printmaster!
Posts: 119
Joined: Mon Nov 17, 2014 10:15 am

Re: Ezstruder stepper motors are over heating

Post by add1ct3dd »

I also use a large fan, I'd rather have more torque than risk it skipping :).

I think the latest batch of steppers used in the kit are not so good.

karlclayton
Plasticator
Posts: 5
Joined: Tue Mar 03, 2015 11:28 pm

Re: Ezstruder stepper motors are over heating

Post by karlclayton »

Thanks for the info.

I used a large fan to cool them down but I will change the current.

I have had to several times unjam the extruder with chewed up filament but that may have been the filament melting with the high heat.

Has anyone used a dedicated mini fan to cool the steppers and if so which build worked for you? Please provide a link to any files with good fan mounts for the extruder steppers. I know there are several on Thingiverse but I would like to know the best experience from someone who has done this already.

User avatar
Renha
Printmaster!
Posts: 282
Joined: Fri Apr 11, 2014 2:18 am
Location: Balashikha, Russian Federation
Contact:

Re: Ezstruder stepper motors are over heating

Post by Renha »

i am going to use peltier with water cooling circuit from kraken, need to design some parts for it, but i'm so lazy... If you interested i could share them when they would be done
3D printing is magic!

Sorry my engrish :-/ you could PM me in Russian.

BenTheRighteous
Printmaster!
Posts: 695
Joined: Fri Nov 07, 2014 9:38 am

Re: Ezstruder stepper motors are over heating

Post by BenTheRighteous »

Here's my approach. I moved the extruder stepper to the top of my machine and pointed an 80mm fan at it. It's perhaps not the most elegant mod, but it gets the job done. My stepper used to get hot enough to melt PLA, now it's cool to the touch even hours into a print.

http://repables.com/r/453/
nitewatchman wrote:it was much cleaner and easier than killing a chicken on top of the printer.

User avatar
Jimustanguitar
ULTIMATE 3D JEDI
Posts: 2631
Joined: Sun Mar 31, 2013 1:35 am
Location: Notre Dame area
Contact:

Re: Ezstruder stepper motors are over heating

Post by Jimustanguitar »

I'm working on a chiller for a cutting laser, and in addition to some radiators I was going to use a peltier element on an aluminum PC cooling block.

Here's the one I was going to use: http://www.amazon.com/gp/product/B00L28 ... UTF8&psc=1

My plan was to chill the water, and then I've got a heatpipe style CPU cooler that I was going to put on the hot side of the peltier.

karlclayton
Plasticator
Posts: 5
Joined: Tue Mar 03, 2015 11:28 pm

Re: Ezstruder stepper motors are over heating

Post by karlclayton »

I changed the extruder motor to a Wantai and the motor is running cool and perfect.

I have decided to change all the motors to Wantai as the tower motors are running hot aswell.

If SeeMeCnc supplies you with anything other than Wantai motors, it is best to change them out to save a lot a time and problems.

Thanks for everyone's help. The next upgrade is optical end stops.

jlmccuan
Printmaster!
Posts: 75
Joined: Mon Feb 09, 2015 11:10 am

Re: Ezstruder stepper motors are over heating

Post by jlmccuan »

I built 2 MAXvII's and used the settings in the build manual for Kysan steppers.

Click on the tab in the Arduino IDE marked “Configuration.h”. At line #701, you should see this text: #define MOTOR_CURRENT {175,175,175,200,0}. Change that line to this: #define MOTOR_CURRENT {155,155,155,165,0}


This resulted in hot motors. Especially the extruder. It would melt PLA and ABS at the hobbed gear and create a huge mess while running and I didn't dare idle it. When I went in to check if my MOTOR_CURRENT settings were correct I noticed a comment.

{140,140,140,160,0} // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A) use 140 for xyz and 160 for the E if using Kysan motors and 175 xyz and 200 if using wantai motors

After changing to the commented settings the motors were much cooler and run without stalling even when pushed very hard.

EL Cuajinais
Printmaster!
Posts: 96
Joined: Wed Feb 18, 2015 9:09 am

Re: Ezstruder stepper motors are over heating

Post by EL Cuajinais »

I just put together a kit and it came with Automation Technology motors. I tried the manual's MOTOR_CURRENT {155,155,155,165,0} and the one you saw in the comments MOTOR_CURRENT {140,140,140,160,0}. Neither worked. Motors are running extremely hot and the PLA gets chewed up by the extruder stepper after about 2 hrs of running (resulting in an AirPrint). Ambient temp here is around 80 deg F.

Post Reply

Return to “Rostock MAX v2”