Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

The one, the only, the Atremis. Forum for the monster metal machine from SeeMeCNC
Post Reply
DDXdesign
Printmaster!
Posts: 66
Joined: Mon Apr 01, 2019 10:56 am

Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by DDXdesign »

OK - SO - after recent troubles I upgraded my Artemis's firmware and it was like having a brand new machine all over again. Flawless leveling, amazing prints, even faster and cleaner than before.

But just today, I went to upload a new model to it over the Duet Wifi, and got this error:
Your Duet rejected the HTTP request: page not found
Check that the SD card is mounted and has the correct files in its /www folder

Went upstairs to the printer and checked the console, did the off/on dance, even simulated a print, no problems.

Came back downstairs, reloaded the wifi interface page, and the error came back.

Back upstairs, did the whole thing again of checking whatever I could. No problems after a restart, again.

Then, though, I decided to check the wifi page from my phone in there where I could watch the machine's front panel. THAT is what triggers a misread on the card, apparently. Instantly: Card Read Error 2. And, back to the same symptoms. So, I have the card in hand now. What can I do here? Naturally, I have to upload new models to print for customers - this never happens when I just want to print things for myself, eh?

Thanks.
geneb
ULTIMATE 3D JEDI
Posts: 5302
Joined: Mon Oct 15, 2012 12:47 pm
Location: Graham, WA
Contact:

Re: Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by geneb »

You may need to replace the card. I'm not sure though. Are you able to put the SD card in your computer and back it up?

You might want to post this on the Duet3D forums and see what they've got to say about it.

g.
Delta Power!
Defeat the Cartesian Agenda!
http://www.f15sim.com - 80-0007, The only one of its kind.
http://geneb.simpits.org - Technical and Simulator Projects
DDXdesign
Printmaster!
Posts: 66
Joined: Mon Apr 01, 2019 10:56 am

Re: Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by DDXdesign »

I can back it up to PC, yes; I actually loaded a new model onto it last night directly from the computer in order to start on this customer order.

Is there any reason for something like that to just work for 2 years or so and then decide to no longer?
geneb
ULTIMATE 3D JEDI
Posts: 5302
Joined: Mon Oct 15, 2012 12:47 pm
Location: Graham, WA
Contact:

Re: Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by geneb »

Without knowing what the error code you got actually means, I can't answer that precisely. SD cards do have a limited lifespan. I would ask the Duet3D folks to explain what the error code is - that would help.

g.
Delta Power!
Defeat the Cartesian Agenda!
http://www.f15sim.com - 80-0007, The only one of its kind.
http://geneb.simpits.org - Technical and Simulator Projects
DDXdesign
Printmaster!
Posts: 66
Joined: Mon Apr 01, 2019 10:56 am

Re: Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by DDXdesign »

hey @geneb I wanted to post an update because it somehow got worse.
Talking with the D3D people they indicated that it was just the SD going bad as well, so I finally was able to replace it.
- Pulled all the files off the old SD except a couple that had an i/o error (maybe the root cause of the issue) and replaced the whole www folder (where those files were) with a new set of files from the github repository for my FW version.
- Loaded those onto a new SD - popped it in the machine - and nothing at all. No macros, no gcodes, no messages coming over the console. And the hotend fans are on full tilt.

It's exactly the same as if I have no SD card in at all (tested to see if that was the case and, sure enough...)
DDXdesign
Printmaster!
Posts: 66
Joined: Mon Apr 01, 2019 10:56 am

Re: Once more - stopped working with no warning after another stint of flawlessness. This time it's the SD card?

Post by DDXdesign »

@PartDaddy - anyone?

Connected to the printer over USB to try to send some commands... got it to connect to the wifi, but still the machine thinks it just doesn't have an SD card in it or something.

m552
WiFi module is disabled<LF>ok<LF>
m552 s0
ok<LF>WiFi module started<LF>
m552 s1
ok<LF>WiFi module is connected to access point MOTO3E2E, IP address 192.168.0.206<LF>
m122 p104 s10
Error: Failed to create folder 0:/gcodes in path 0:/gcodes/test.tst<LF>Error: M122: Failed to create file<LF>ok<LF>
m997 s1
Error: M997: File DuetWiFiServer.bin not found<LF>ok<LF>
Post Reply

Return to “Artemis”